Knowledge Base/Tango Knowledge Base/Tango for PC

(PC) What do I need to use Tango?

Tango Support
posted this on August 16, 2011 15:12

Q: What  do I need to use Tango?


A: Please ensure that your system meets these requirements, and that you download the latest version of Tango from http://www.tango.me/download

Internet Connection Broadband (e.g. Cable or DSL)
Operating System XP, Vista, or Windows 7 
Computer Processor  1 GHz or greater
Computer Memory 1 GB or greater
Additional 

Webcam
Speakers and Microphone, or Headset

 
Topic is closed for comments